Joomla 3.0.4 or higher Joomla 3.1Joomla 3.2

Installing cedSecurityImages is no different than installing any other Joomla!™ extension on your site. You can read the complete instructions for installing Joomla!™ extensions on the official help page [http://help.joomla.org/content/view/1476/235/]. Throughout this chapter we assume that you are familiar with these instructions and we will try not to duplicate them. Installing or manually updating the component and language files Just like with most Joomla! extensions there are two ways to install or manually update cedSecurityImages on your site: Upload and install. That's the typical extension installation method for Joomla! extensions. It rarely fails. Manual installation. This is the hardest, but virtually fail-safe, installation method. Please note that installing and updating cedSecurityImages (and almost all Joomla! extensions) is actually the same thing. If you want to update cedSecurityImages please remember that you MUST NOT uninstall it before installing the new version! When you uninstall cedSecurityImages you will lose all your settings. This is definitely something you do not want to happen! Instead, simply install the new version on top of the old one. Joomla! will figure out that you are doing an update and will treat it as such, automatically. Tip If you find that after installing or updating cedSecurityImages it is missing some features or doesn't work, please try installing the same version a second time, without uninstalling the component. The reason is that very few times the Joomla! extensions installer infrastructure gets confused and fails to copy some files or entire folders. By repeating the installation you force it to copy the missing files and folders, solving the problem. Upload and install.

You can download the latest installation packages our site's download page for cedSecurityImages [http://www.galaxiis.com/cedsecurityimages-download/]. Please note that the latest version is always on top. If you have an older Installation, updates and upgrades version of Joomla! or PHP please consult our Compatibility page [compatibility.html] to find the version of cedSecurityImages compatible with your Joomla! and PHP versions. In either case click on the version you want to download and install. Click on the cedSecurityImages item to download the ZIP installation package. All cedSecurityImages installation packages contain the component and all of its associated extensions. Installing it will install all of these items automatically. It can also be used to upgrade cedSecurityImages; just install it without uninstalling the previous release. In any case, do not extract the ZIP files yet! Attention Mac OS X users Icon Safari, the default web server provided to you by Apple, is automatically extracting the ZIP file into a directory and removes the ZIP file. In order to install the extension through Joomla!'s extensions installer you must select that directory, right-click on it and select Compress to get a ZIP file of its contents. This behavior was changed in Mac OS X Mountain Lion, but people upgrading from older versions of Mac OS X (Mac OS X Lion and earlier) will witness the old, automatic ZIP extraction, behavior Log in to your site's administrator section. Click on Extensions, Manage link on the top menu. If you are on Joomla! 3.x please click on the Upload Package File tab. Locate the Browse button next to the Package File (Joomla! 2.5, 3.0 and 3.1) or Extension package file (Joomla! 3.2 and later) field. Locate the installation ZIP file you had previously downloaded and select it. Back to the page, click on the Upload & Install button. After a short while, Joomla!™ will tell you that the component has been installed. If the installation did not work, please take a look at our installation troubleshooting instructions [http://troubleshooter.html] or try the manual installation described below.

Checking for the latest version and upgrading You can easily check for the latest published version of the cedSecurityImages component by visiting http://www.galaxiis.com/cedSecurityImages/latest. The page lists the version and release date of the latest cedSecurityImages release. You can check it against the data which appear on the right-hand pane of your cedSecurityImages Control Panel. If your release is out of date, simply click on the Download link to download the install package of the latest release to your PC.

cedSecurityImages can be updated just like any other Joomla! extension, using the Joomla! extensions update feature. Joomla! is responsible for finding the updates, downloading them and installing them on your server. You can access the extensions update feature in two different ways: From the icon your Joomla! administrator control panel page. On Joomla! 3 you will find the icon in the left-hand sidebar, under the Maintenance header. It has an icon which looks like an empty star. On Joomla! 2.5 you will find it in the main area of the control panel page, under Quick Icons. When there are updates found for any of your Installation, updates and upgrades extensions you will see the Updates are available message. Clicking on it will get you to the Update page of Joomla! Extensions Manager. From the top menu of your Joomla! administrator click on Extensions, Extensions Manager. From that page click on the Update tab found in the left-hand sidebar on Joomla! 3 and the top navigation bar in Joomla! 2.5. Clicking on it will get you to the Update page of Joomla! Extensions Manager. If you do not see the updates try clicking on the Find Updates button in the toolbar. If you do not see the updates still you may want to wait up to 24 hours before retrying. This has to do with the way the update CDN works and how Joomla! caches the update information. Unfortunately we can't do anything about it, especially in Joomla! 3 (there is no way to forcibly clean the updates cache). If there is an update available for cedSecurityImages tick the box to the left of its row and then click on the Update button in the toolbar. Joomla! will now download and install the update.

As noted in the installation section, installing and updating cedSecurityImages is actually the same thing. If the automatic update using Joomla!'s extensions update feature does not work, please install the update manually following the instructions in the installation section of this documentation. Important When installing an update manually you MUST NOT uninstall your existing version of cedSecurityImages. Uninstalling cedSecurityImages will always remove all your settings. You definitely not want that to happen!

Support is provided only to subscribers. If you already have an active subscription which gives you access to the support. You can request support for it through our site. You will need to log in to our site and go to Support and click on the New Ticket button. If you can't see the button please use the Contact Us page to let us know of the ticket system problem and remember to tell us your username. If you want to report a bug, please use the Contact Us page of our site. You don't need to be a subscriber to report a bug. Please note that unsolicited support requests sent through the Contact Us page will not be addressed. If you believe you are reporting a bug please indicate so in the contact form.

Support cannot be provided over Twitter, Facebook, email, Skype, telephone, the official Joomla! forum, our Contact Us page or any other method except the Support section on our site. We also cannot take bug reports over any other medium except the Contact Us page and the Support section on our site. Support is not provided to non-subscribers; if you are using the Core version you can request support from other users in the official Joomla! forum or any other Joomla!-related forum in your country/region. We have to impose those restrictions in support to ensure a high level of service and quality. Thank you for your understanding.

You can uninstall the component just like any other Joomla! component. In your site's back-end, just go to Extensions Manager, click on Uninstall, select cedSecurityImages and click on Uninstall. This will completely remove cedSecurityImages including all plugins and modules.

keycaptcha

KeyCAPTCHA is the first free service providing a powerful anti-spam website protection through a new generation interactive CAPTCHA. You may support charity funds by enabling social advertising in KeyCAPTCHA. Also you can earn money by specifying social and commercial advertising shares in KeyCAPTCHA on your website.

Support is provided only to subscribers. If you already have an active subscription which gives you access to the support. You can request support for it through our site. You will need to log in to our site and go to Support and click on the New Ticket button. If you can't see the button please use the Contact Us page to let us know of the ticket system problem and remember to tell us your username. If you want to report a bug, please use the Contact Us page of our site. You don't need to be a subscriber to report a bug. Please note that unsolicited support requests sent through the Contact Us page will not be addressed. If you believe you are reporting a bug please indicate so in the contact form.

Support cannot be provided over Twitter, Facebook, email, Skype, telephone, the official Joomla! forum or any other method except the Support section on our site. We also cannot take bug reports over any other medium except our Contact Us page and the Support section on our site. Support is not provided to non-subscribers; if you are using the Core version you can request support from other users in Galaxiis forum , the official Joomla! forum or any other Joomla!-related forum in your country/region. We have to impose those restrictions in support to ensure a high level of service and quality. Thank you for your understanding.